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About This Manual

This manual is for manufacturing test engineers who need to acquire 
images of parts, process and analyze the images, make measurements, and 
make pass/fail decisions about the parts. This manual is well suited for 
people who have little experience with machine vision. The manual 
contains many techniques for using NI Vision Builder for Automated 
Inspection (Vision Builder AI) to solve visual inspection tasks including 
inspection, gauging, part presence, guidance, and counting.

Follow the instructions in this manual to familiarize yourself with the 
Vision Builder AI Configuration interface and solve common inspection 
tasks.

Conventions
The following conventions appear in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represent a 
range of values associated with a bit or signal name—for example, 
DIO<3..0>.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.



About This Manual

NI Vision Builder for Automated Inspection Tutorial viii ni.com

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

Related Documentation
The following documents contain information that you might find helpful 
as you read this manual:

• NI Vision Builder for Automated Inspection: Configuration Help, 
available by selecting Help»Online Help from the Vision Builder AI 
Configuration interface

• NI Vision Builder for Automated Inspection: Inspection Help, 
available by selecting Help»Online Help from the Vision Builder AI 
Inspection interface

• NI Vision Builder for Automated Inspection Release Notes, available 
from Start»Programs»National Instruments»Vision Builder AI»
Documentation
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1
Getting Started in 
Vision Builder AI

This chapter introduces the Vision Builder AI environment, teaches you 
how to create a short inspection, and shows you how to run an inspection. 

Figures 1-1 and 1-2 show the general instructions for creating a 
Vision Builder AI inspection. Figure 1-1 describes the general steps for 
designing a Vision Builder AI inspection. The Add Inspection Steps module 
of Figure 1-1 is expanded in Figure 1-2.
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Figure 1-1.  General Instructions for Creating a Vision Builder AI Inspection
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Figure 1-2.  Adding Inspection Steps to a Vision Builder AI Inspection
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Follow the instructions in this chapter to open Vision Builder AI and 
configure, test, save, and run an inspection.

Opening the Vision Builder AI Configuration Interface
Vision Builder AI has two modes of operation: configuration and 
inspection. Use the Configuration interface to configure and test your 
inspection. Use the Inspection interface to deploy the software and perform 
online or offline visual inspection.

Follow these instructions to open the Vision Builder AI Configuration 
interface.

1. Go to the Start menu and select Programs»National Instruments 
Vision Builder AI. The Welcome screen opens.

2. Click Configure Inspection.

Elements of the Configuration Interface
Figure 1-3 shows the Vision Builder AI Configuration interface. The 
Configuration interface contains four areas: Main window, Inspection 
Diagram window, Inspection Steps palette, and Embedded Help 
window.
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Figure 1-3.  Vision Builder AI Configuration Interface

• Main window—Displays the image being processed, the DataSocket 
I/O property page, the Modbus Slave property page, the 
Decision Making property page, the Serial I/O property page, and 
the Configure Inputs/Outputs property page.

• Inspection Diagram window—Displays the sequence of Vision 
Builder AI steps that comprise the inspection.

• Inspection Steps palette—Lists and describes the steps you can use 
to create your inspection. Each tab in the palette represents a common 
machine vision task, such as acquiring an image or locating features in 

1 Main Window
2 Inspection Diagram Window

3 Inspection Steps Palette
4 Embedded Help Window

2 3
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an image. When you click most steps, the palette transforms into the 
property page for the step.

• Embedded Help window—Contains context-sensitive help about 
when to use a step, how to configure a step, the function of the 
user-interface controls, and frequently asked questions.

Configuring an Inspection
On startup, Vision Builder AI loads a blank inspection in the Inspection 
Diagram window. To build an inspection, you need to add and configure 
steps to the inspection.

This section teaches you how to create a simple inspection that checks for 
the presence of a label on a National Instruments FieldPoint device.

Acquiring an Image
In the Inspection Steps palette, the Acquire Images tab 
contains acquisition steps—Acquire Image and Acquire Image 
(IEEE 1394)—and a Simulate Acquisition step, which simulates 
image acquisition by loading images from file. The tab also contains a 
Select Image step, which enables you to switch to a previously acquired 
image that you need to process later in the inspection.

Note For simplicity, the exercises in this tutorial instruct you to use the 
Simulate Acquisition step. However, in your real-world inspection, use one of the image 
acquisition steps to acquire images of the object under inspection.

Follow these instructions to configure a Simulate Acquisition step that 
simulates acquiring images of FieldPoint devices.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Simulate Acquisition step. The property page for the step 
opens. 

3. In the Step Name control, enter Acquire Image.

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Vision Builder AI>\DemoImg\Tutorial 1. 

Note If you installed Vision Builder AI in the default directory, you can find <Vision 
Builder AI> in the C:\Program Files\National Instruments directory.
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6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled. 
When this control is enabled, Vision Builder AI loads a different 
simulation image from the folder each time the step is run, which 
simulates a live acquisition of multiple parts.

8. Click OK. Vision Builder AI adds the Simulate Acquisition step to 
the inspection.

Checking for the Presence of a Feature Using Match Pattern
Follow these instructions to configure a Match Pattern step to check for 
the presence of the FieldPoint device label.

1. In the Inspection Steps palette, select the Check for Presence tab.

Note If a Vision Builder AI step can perform more than one machine vision task, the step 
appears under each applicable Inspection Steps tab. For example, the Match Pattern step 
appears in the Locate Features tab as well as the Check for Presence tab. A step that 
appears in multiple tabs functions identically in each tab it is located.

2. Click the Match Pattern step. The Select a template in the image 
dialog box opens.

3. Draw a region of interest (ROI) around the area of the image 
containing the label, as shown in Figure 1-4. This region becomes the 
pattern matching template. 
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Figure 1-4.  Creating a Template Pattern

4. Click OK to accept the template.

Notice that Vision Builder AI locates the specified template in the 
green ROI. The location of the match is overlaid on the inspection 
image with a red rectangle.

5. In the Main tab, enter Locate Label in the Step Name control.

6. Redraw or decrease the default green ROI so that it surrounds only the 
portion of the device that contains the learned template, as shown in 
Figure 1-5.
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Figure 1-5.  Limiting the Search Region

This ROI represents the area of the image in which Vision Builder AI 
searches for instances of the template.

7. In the Settings tab, set Number of Matches to Find to 1.

Notice the Minimum Score control. By default, all instances of the 
template must have a match score of 800 or higher to be considered a 
valid match. Minimum Score can vary between 0 and 1,000. A match 
score of 1,000 indicates a perfect match.

8. In the Limits tab, enable the Minimum Number of Matches control, 
and set the value to 1.

Notice the Matches table contains two matches—a match that meets 
the requirements you set and the next best possible match. This feature 
helps you choose a minimum score high enough to discriminate 
correct parts from defective ones but not so high that the visual 
inspection cannot tolerate normal process variations.
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Testing an Inspection Step
You can test a step before or after adding it to the inspection. Follow these 
instructions to test the Locate Label step to make sure the current step 
configuration returns the results you expect.

1. Click the Run Once button located in the Inspection Diagram 
window.

Vision Builder AI loads the next image, Image 02.jpg, from the 
Tutorial 1 folder and performs the Locate Label step on the image.

Note The name of the active image is displayed in the Simulate Acquisition module of 
the inspection diagram.

Notice that the value of Step Status is PASS.

2. Test the other images in the Tutorial 1 folder. Table 1-1 lists the test 
images, the step status to expect for each image, and an explanation of 
the status.

Note If Image 02.jpg, Image 03.jpg, or Image 04.jpg do not pass inspection, 
slightly reduce the value of the Minimum Score control located in the Settings tab.

3. Click OK to add the step to the inspection.

Saving an Inspection
Follow these instructions to save the example inspection.

1. Select File»Save. An Inspection Properties dialog box opens.

2. In the Inspection Name control, enter Lesson 1.

Table 1-1.  Expected Results for the FieldPoint Label Inspection

Image Name Inspection Status Explanation

Image 03.jpg PASS The label is present.

Image 04.jpg PASS The label is present.

Image 05.jpg FAIL The label is missing.

Image 06.jpg FAIL The label is upside down.
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3. In the Description field, enter the following:

This inspection checks for the proper application 

of a label on a FieldPoint module using pattern 

matching.

4. Click Save to save the inspection and its description.

Running an Inspection in the Inspection Interface
As mentioned in the Opening the Vision Builder AI Configuration Interface 
section, you deploy and run an inspection from the Vision Builder AI 
Inspection interface. Figure 1-6 shows the Inspection interface, which has 
three main areas: the Results panel, the Inspection Statistics panel, and 
the Display window.

Figure 1-6.  Vision Builder AI Inspection Interface

1 Results Panel 2 Display Window 3 Inspection Statistics Panel

1 2

3
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• Results panel—Lists the steps in the inspection by name. For each 
inspection step, Vision Builder displays the step type, result (PASS or 
FAIL), measurement made, and a comment explaining the reason of a 
FAIL. Inspection Status shows the result of the complete inspection.

• Display window—Displays the part under inspection.

• Inspection Statistics panel—Contains three indicators that display 
the yield (ratio between PASS and FAIL), active versus idle time, and 
processing time of the inspection.

Follow these instructions to run the inspection from the Inspection 
interface.

1. Select File»Switch to Inspection Interface to launch the Inspection 
interface. The steps of Lesson 1 are listed in the Results panel.

2. Click the Start Inspection button. Vision Builder AI begins running 
the inspection on the simulation images and updating the three areas of 
the Inspection interface with the most recent inspection data.

By default, Vision Builder AI displays all the inspection images in the 
Display window. You can change the display settings in the View 
menu to view only images that fail or to have no display. You also can 
change the magnification of the displayed images in the Options 
menu.

Notice the performance data displayed in the Inspection Statistics 
panel. This data can help you determine how efficiently your 
inspection is running. Based on this data, you can make adjustments to 
improve the inspection speed.

3. Click the Stop Inspection button to stop the inspection.

4. Select File»Switch to Configuration Interface to return to the 
Configuration interface.
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2
Checking for the Presence of 
a Part

This chapter introduces the Measure Intensity and Set Coordinate 
System steps. Follow the instructions in this chapter to create an inspection 
that checks for the presence of a spray bottle cap regardless of the bottle 
position in the inspection images.

Note Launch Vision Builder AI if it is not open. Refer to the Opening the Vision Builder 
AI Configuration Interface section of Chapter 1, Getting Started in Vision Builder AI, for 
more information.

Creating a New Inspection
Select File»New. Vision Builder AI loads a new, blank inspection into the 
Inspection Diagram window.

Simulating Image Acquisition
Follow these instructions to configure a Simulate Acquisition step that 
simulates acquiring images of spray bottles.

1. In the Inspection Steps palette, select the Acquire Images tab. 

2. Click the Simulate Acquisition step. The property page for the step 
opens. 

3. In the Step Name control, enter Acquire Spray Bottle.

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Vision Builder AI>\DemoImg\Tutorial 2.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled so 
that Vision Builder AI loads a different simulation image from the 
folder each time the step is run.

8. Click OK to add this step to the inspection.
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Defining a Feature on Which to Base a 
Coordinate System

In a machine vision inspection, you typically limit your inspection and 
processing to a region of interest (ROI) rather than the entire image for the 
following reasons:

• To improve your inspection results by avoiding extraneous objects

• To increase inspection speed

To limit the inspection area, the parts of the object you are interested in 
must always be inside the ROI you define.

If the object under inspection is fixtured and always appears at the same 
location and orientation in the images you need to process, defining an ROI 
is straightforward. However, if the object under inspection appears shifted 
or rotated within the images, the regions of interest need to shift and rotate 
with the object under inspection. 

For the regions of interest to move in relation to the object, you need to set 
a coordinate system relative to a significant and original feature of the 
object under inspection. Choose a feature that is always in the field of view 
of the camera despite the different locations that the objects may appear in 
from image to image. Also, make sure the feature is not affected by major 
defects that could drastically modify the visual appearance of the feature.

Follow these instructions to configure a Match Pattern step that locates a 
bottle feature on which you can base a coordinate system.

1. In the Inspection Steps palette, select the Locate Features tab. 

2. Click the Match Pattern step. The Select a template in the image 
dialog box opens.

3. Draw an ROI around the base of the sprayer, as shown in Figure 2-1. 
This region becomes the pattern matching template. 
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Figure 2-1.  Creating a Template Pattern

4. Click OK to accept the template. 

5. In the Main tab, enter Locate Sprayer Base in the Step Name 
control.

The green ROI specifies the area of the image in which Vision Builder AI 
tries to locate the template. Assuming that the bottles are fixtured in such a 
way that they can move only horizontally within the field of view, you can 
limit the ROI so that it surrounds only the area of the image that may 
contain a template match during inspection.

6. Redraw or decrease the default green ROI so that it surrounds only the 
lower portion of the image, as shown in Figure 2-2.
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Figure 2-2.  Limiting the Search Region

7. In the Template tab, drag the red crosshair mark in the template image 
to the left edge of the sprayer base, as shown in Figure 2-3. This 
changes the focal point of the template. 

The focal point indicates the part of the template that you want to 
return as the match location. By default, the focal point is the center of 
the template. You can modify the focal point by moving the red 
crosshair or by specifying a Match Offset. Later in this inspection, you 
use the match location as the origin of a coordinate system.
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Figure 2-3.  Adjusting the Focal Point of the Template

8. In the Settings tab, set Number of Matches to Find to 1.

9. In the Limits tab, enable the Minimum Number of Matches control, 
and set the value to 1.

10. Click OK to add the step to the inspection.

Setting a Coordinate System
Follow these instructions to configure a Set Coordinate System step based 
on the Match Pattern step you configured.

1. In the Inspection Steps palette, select the Locate Features tab. 

2. Click the Set Coordinate System step.

3. In the Main tab, enter Coordinate System in the Step Name 
control.

4. In the Settings tab, select Horizontal and Vertical Motion from the 
Mode control because the bottles appear shifted but not rotated from 
one image to another.

1 Focal Point

1
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Notice the Origin list. Match 1, the match location of the previous 
Locate Sprayer Base step, is the default origin of the coordinate 
system because it is the only location point created by previous steps 
in the inspection.

5. Click OK to add this step to the inspection.

Checking for the Cap Using Measure Intensity
You can check for the presence of the cap by measuring the pixel intensities 
in the regions you expect the cap to be located. Follow these instructions to 
configure a Measure Intensity step that checks for the presence of a spray 
bottle cap.

1. In the Inspection Steps palette, select the Check for Presence tab.

2. Click the Measure Intensity step. The property page for the step 
opens.

3. In the Main tab, enter Check Cap Presence in the Step Name 
control.

4. Enable the Reposition Region of Interest control. 

Enabling this control allows you to link the regions of interest specified 
in this step to a previously defined coordinate system so that 
Vision Builder AI can adjust the location and orientation of the ROI 
from image to image relative to the specified coordinate system. 

The Reference Coordinate System list shows all the previously 
defined coordinate systems. Coordinate System is the default 
reference coordinate system because it is the only Set Coordinate 
System step in the current inspection.

Notice that the Measure Intensity step supports a variety of different tools 
that enable you to draw different shaped regions of interest, such as a point, 
line, broken line, freehand line, rectangle, ellipse, annulus, polygon, and 
freehand region. These tools are available in the main menu bar.

5. Using the default Rectangle Tool, hold down <Ctrl> to enable 
drawing multiple regions of interest, and draw three regions of interest 
that enclose edges of the cap, as shown in Figure 2-4.
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Figure 2-4.  Defining Regions in Which to Measure Intensity

6. Select the Limits tab. 

At the bottom of the tabbed page, Vision Builder AI returns the 
intensity statistics of the pixels inside the regions of interest. Pixel 
intensities can range from 0–255, where 0 equals black and 255 equals 
white. 

The Minimum Intensity value at the bottom of the page returns the 
lowest pixel value inside the regions of interest. The backlit edges of 
the plastic cap appear in silhouette as dark pixels (which have low pixel 
intensities) on a bright background (which has high pixel intensities).

Therefore, when the cap is present, the minimum intensity for the 
regions is low. When the cap is not present, the minimum intensity for 
the regions is high because the regions contain only bright background 
pixels.

7. Enable the Minimum Intensity control. Set the Maximum value 
to 50.00.
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8. Click the Run Once button located in the Inspection Diagram 
window.

Vision Builder AI loads the next image, Image 02.jpg, from the 
Spray Bottle folder. 

Notice that the bottle appears closer to the left edge of the image. 
Vision Builder AI repositions the regions of interest based on the new 
location of the bottle. The Step Status for the image is PASS because 
the presence of the cap inside the regions of interest causes the 
Minimum Intensity value to fall within the limits you set.

9. Test the other images in the Tutorial 2 folder. The following table 
lists the test images, inspection status to expect for each image, and an 
explanation of the status.

10. Click OK to add the step to the inspection.

Defining a Custom Overlay
By default, Vision Builder AI displays the last analyzed image at the end 
of each inspection. However, you can display an image including custom 
overlay elements at any point of the inspection using the Display Image 
step. 

Follow these instructions to configure a Display Image step that specifies 
a custom overlay. 

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Display Image step. The property page for the step opens.

3. Enter Display Image in the Step Name control.

4. Click Edit Custom Overlay. The Setup Custom Overlay property 
page opens.

5. Click Add Text. 

Table 2-1.  Expected Results for the FieldPoint Label Inspection

Image Name Inspection Status Explanation

Image 03.jpg PASS The cap is present.

Image 04.jpg PASS The cap is present.

Image 05.jpg FAIL The cap is missing.
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6. In the Text control, type Minimum Cap Intensity =.

7. Click Insert Data.

8. In the Inspection Data tree, expand Steps Data»Check Cap 
Presence.

9. Select Minimum Intensity, and click OK.

10. Click OK in the Overlay Text dialog box to validate the text to 
display.

11. Click Add Boolean. The Overlay Boolean Indicator dialog box 
opens.

12. In the Inspection Data tree, expand Inspection Information and 
select Inspection Status.

13. Type PASS in the True Case String control.

14. Type FAIL in the False Case String control.

15. Set the Indicator Position Y control to 45.

16. Click OK to validate the overlay of the Boolean indicator.

17. Click OK in the Setup Custom Overlay dialog box to validate the 
overlay.

18. Click OK to add the Display Image step to the inspection.

Saving the Inspection
Save the example inspection with the following name and description.

• Inspection Name—Lesson 2

• Description—This inspection checks for the presence 

of a cap on a spray bottle using an intensity 

measurement and a coordinate system that is based 

on pattern matching.

Refer to the Saving an Inspection section of Chapter 1, Getting Started in 
Vision Builder AI, for more information.
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3
Inspecting Objects for Correct 
Measurements

This chapter introduces the Calibrate Image, Detect Objects, and 
Geometry steps. Follow the instructions in this chapter to create an 
inspection that measures the distance between holes in a gasket to verify 
that the gasket conforms to manufacturing specifications.

Note Launch Vision Builder AI if it is not open. Refer to the Opening the Vision Builder 
AI Configuration Interface section of Chapter 1, Getting Started in Vision Builder AI, for 
more information.

Creating a New Inspection
Select File»New. Vision Builder AI loads a new, blank inspection into the 
Inspection Diagram window.

Simulating Image Acquisition
Follow these instructions to configure a Simulate Acquisition step that 
simulates acquiring images of gaskets.

1. In the Inspection Steps palette, select the Acquire Images tab. 

2. Click the Simulate Acquisition step. The property page for the step 
opens. 

3. In the Step Name control, enter Acquire Gasket.

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Vision Builder AI>\DemoImg\Tutorial 3.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled so 
that Vision Builder AI loads a different simulation image from the 
folder each time the step is run.

8. Click OK to add the step to the inspection.
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Calibrating Images
By default, Vision Builder AI returns measurements in pixel units. If you 
want the inspection to return measurements in real-world units, you need to 
map pixel units to real-world units through a process called spatial 
calibration.

Follow these instructions to configure a Calibrate Image step that defines 
the type of calibration, the calibration parameters, and the real-world unit 
in which you want to express measurements.

1. In the Inspection Steps palette, select the Enhance Images tab.

2. Click the Calibrate Image step.

3. In the Step Name control, enter Calibrate Gasket.

4. Click New Calibration to launch the calibration wizard.

For this example, assume that the camera that acquired the inspection 
images is perpendicular to the image plane and lens distortion is negligible. 
Based on these assumptions, you can use Simple Calibration to calibrate 
your images. Simple Calibration transforms a pixel coordinate to a 
real-world coordinate through scaling in the x (horizontal) and y (vertical) 
directions. 

5. Double-click Simple Calibration to open the Simple Calibration 
Setup dialog box.

6. In Step 1 of 3, make sure Pixel Type is set to Square because the 
camera that acquired the images for this exercise has square pixels.

7. Click Next.

8. In Step 2 of 3, carefully click the 0 mm and 50 mm markings on the 
ruler in the image, as shown in Figure 3-1.

Tip You may need to scroll down to see the ruler at the bottom of the image.
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Figure 3-1.  Specifying the Pixel Ratio

9. In the Correspondence Image - Real World control, enter 50 for the 
value, and select millimeter for the Unit.

10. Click Next.

In Step 3 of 3, you can define the origin and angle of the calibration axis 
anywhere in the image. By default, the bottom, left pixel in the image is the 
calibration axis origin, and the horizontal axis of the image is the 
calibration axis angle. Use the default calibration axis settings for this 
exercise.

Tip In some applications, you may want to measure between a fixed reference feature on 
the part and other features in the image. Setting the origin of the calibration axis to the 
location of the reference feature simplifies making measurements because the starting 
point for the measurements becomes 0.
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11. Click OK to learn the calibration information and exit the calibration 
wizard. 

The Calibration and Axis tabs display information about the learned 
calibration.

12. Click OK to add the step to the inspection.

Tip You can save the calibration information you set up in the wizard so that you can use 
the information later to calibrate images in another inspection. To save the calibration 
information, enable the Save Calibrated Image to File control, and specify a file path to 
which you want to save the calibrated image. When you click OK to add the step to the 
inspection, Vision Builder AI saves the calibrated file.

Locating Features to Measure
Follow these instructions to configure a Detect Objects step that finds 
small holes in the gasket.

1. In the Inspection Steps palette, select the Check for Presence tab. 

2. Click the Detect Objects step. The property page for the step opens.

3. In the Step Name control, enter Detect Small Holes.

4. Using the default Rectangle Tool, draw a region of interest (ROI) 
around the entire gasket, as shown in Figure 3-2.
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Figure 3-2.  Defining the ROI

5. In the Threshold tab, select the Bright Objects control.

Notice that the blue shading highlights all bright pixels—pixels with 
high intensity values that fall within the Threshold Range—in the 
ROI. Vision Builder AI groups contiguous highlighted pixels into 
objects, which are depicted by red bounding rectangles.

6. Click the Settings tab.

The step locates four objects, which are listed in Table 3-1.
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Object 1 and Object 4 are the small holes of interest in this step. Use 
the Minimum Object Size and Maximum Object Size controls of 
the Detect Objects step to eliminate objects of no interest based on 
their size.

7. Enable the Minimum Object Size and Maximum Object Size 
controls.

Based on the information in Table 3-1, the small holes have sizes of 
62.43 mm2 and 61.50 mm2.

8. Set Minimum Object Size to 50 and Maximum Object Size to 70.

9. In the Limits tab, enable the Minimum Number of Objects and 
Maximum Number of Objects controls. Set their values to 2.

10. Click OK to add this step to the inspection.

Follow these instructions to find the large hole in the gasket.

1. Right-click the Detect Small Holes step in the Inspection Diagram 
window. A shortcut menu opens.

2. Select Copy.

3. Right-click the Detect Small Holes step again.

4. Select Paste. A copy of the Detect Small Holes step is placed after the 
original step.

5. Double-click the Detect Small Holes copy or click the Edit Step 
button to launch the property page of the step for editing.

6. In the Step Name control, enter Detect Large Hole.

7. Select the Settings tab. 

Based on the information in Table 3-1, the large hole has a size of 
1410 mm2.

8. Set Minimum Object Size to 1300 and Maximum Object Size 
to 1450.

Table 3-1.  Sizes of Gasket Holes

Object Number Size (pix2) Size (mm2)

1 1,807 62.43

2 13,351 461.26

3 40,816 1,410.15

4 1,780 61.50
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9. In the Limits tab, enable the Minimum Number of Objects and 
Maximum Number of Objects controls. Set their values to 1.

10. Click OK to update the inspection.

Note Vision Builder AI returns the centers of mass for the holes as their locations.

Measuring Parts of the Gasket
Follow these instructions to measure the distance from the top small hole 
to the large hole to inspect whether the distance meets specifications.

1. In the Inspection Steps palette, select the Measure Features tab. 

2. Click the Geometry step. The property page for the step opens.

3. In the Step Name control, enter Top Distance.

4. In the Geometric Feature control, select the Distance measurement.

5. Select points 1 and 3 by clicking the points in the image or selecting 
the points from the Available Points list.

6. In the Limits tab, enable the Minimum Distance control and set it 
to 32. Enable the Maximum Distance control and set it to 35.

7. Click OK to add the step to the inspection.

Follow these instructions to measure the distance from the large hole to the 
bottom small hole to inspect whether the distance meets specifications.

1. In the Inspection Steps palette, select the Measure Features tab.

2. Click the Geometry step. The property page for the step opens.

3. In the Step Name control, enter Bottom Distance.

4. In the Geometric Feature control, select the Distance measurement.

5. From the Available Points list, select 2 and 3, which correspond to the 
bottom small hole and large hole, respectively.

6. In the Limits tab, enable the Minimum Distance control and set it 
to 38. Enable the Maximum Distance control and set it to 40.

7. Click OK to add the step to the inspection.
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Testing the Inspection
Test the inspection to make sure it returns the results you expect. The 
following table lists the test images, the inspection status to expect for each 
image, and an explanation of the status.

Refer to the Testing an Inspection Step in Chapter 1, Getting Started in 
Vision Builder AI, for more information.

Saving the Inspection
Save the example inspection with the following name and description:

• Inspection Name—Lesson 3

• Description—This inspection locates holes in a gasket 

and measures the distance between the holes.

Refer to the Saving an Inspection section of Chapter 1, Getting Started in 
Vision Builder AI, for more information.

Table 3-2.  Expected Results for the Gasket Inspection

Image Name Inspection Status Explanation

Image 01.jpg PASS All steps passed.

Image 02.jpg PASS All steps passed.

Image 03.jpg PASS All steps passed.

Image 04.jpg FAIL The Top Distance step 
failed because the distance 
between the holes is too 
small.

Image 05.jpg FAIL The Detect Small Holes 
step failed because the 
bottom hole is missing. 
The missing hole also 
caused the Bottom 
Distance step to fail.



© National Instruments Corporation 4-1 NI Vision Builder for Automated Inspection Tutorial

4
Inspecting for Multiple Correct 
Instances of an Object

This chapter introduces the Find Straight Edge, Caliper, and Decision 
Making steps. Follow the instructions in this chapter to create an 
inspection that measures the distance between the blade connectors of a 
fuse and checks the integrity of the fuse conductor regardless of the fuse 
position or whether the fuse is inverted.

Note Launch Vision Builder AI if it is not open. Refer to the Opening the Vision Builder 
AI Configuration Interface section of Chapter 1, Getting Started in Vision Builder AI, for 
more information.

Creating a New Inspection
Select File»New. Vision Builder AI loads a new, blank inspection into the 
Inspection Diagram window.

Simulating Image Acquisition
Follow these instructions to configure a Simulate Acquisition step that 
simulates acquiring images of fuses.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Simulate Acquisition step. The property page for the step 
opens. 

3. In the Step Name control, enter Acquire Fuse.

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Vision Builder AI>\DemoImg\Tutorial 4.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled so 
that Vision Builder AI loads a different simulation image from the 
folder each time the step is run.

8. Click OK to add the step to the inspection.
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Defining a Feature on Which to Base a Coordinate 
System

The fuses can appear shifted horizontally and slightly rotated from one 
inspection image to another. Follow these instructions to configure a 
Find Straight Edge step that finds the left edge of the fuse so that regions 
of interest in subsequent steps can shift with the fuse.

1. In the Inspection Steps palette, select the Locate Features tab. 

2. Click the Find Straight Edge step. The property page for the step 
opens.

3. In the Step Name control, enter Locate Fuse Left Edge.

4. Draw a region of interest (ROI) across the left edge of the fuse, as 
shown in Figure 4-1.

Figure 4-1.  Finding a Straight Edge
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Notice that the ROI contains blue search lines. The step searches along 
the search lines for sharp transitions in pixel intensities, which usually 
represent object edges. The step fits a straight line through the 
individual detected edge points of each search line to determine the left 
edge of the fuse.

5. Click OK to add this step to the inspection.

Setting a Coordinate System
Follow these instructions to configure a Set Coordinate System step based 
on the Find Straight Edge step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Set Coordinate System step. The property page for the step 
opens.

3. In the Main tab, enter Coordinate System in the Step Name 
control.

4. In the Settings tab, select Horizontal Motion from the Mode control.

Notice the Origin list. Point 1, the first point of the straight line detected 
by the Locate Fuse Left Edge step, is the default origin of the coordinate 
system. In this exercise, the location of the origin does not affect the 
measurement you need to make. Therefore, use the default origin.

5. Click OK to add this step to the inspection.

Measuring the Separation between Connectors
Follow these instructions to configure a Caliper step that measures the 
distance between the blade connectors of the fuse.

1. In the Inspection Steps palette, select the Measure Features tab.

2. Select the Caliper step. The property page for the step opens.

3. In the Main tab, enter Separation in the Step Name control.

4. Enable the Reposition Region of Interest control.

5. Draw an ROI across the blade connectors, as shown in Figure 4-2.
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Figure 4-2.  Measuring the Distance Between Two Edges

6. In the Settings tab, select the Process named Vertical Min Caliper to 
change the direction and orientation of the caliper search lines.

7. In the Limits tab, enable the Minimum Distance (Pixels) control and 
set the value to 150. Enable the Maximum Distance (Pixels) control 
and set the value to 160. 

8. Click OK to add this step to the inspection.

Inspecting the Fuse Conductor
Follow these instructions to configure Match Pattern steps that inspect the 
integrity of the fuse conductor.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Match Pattern step. The Select a template in the image 
dialog box opens.
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3. Draw an ROI around the conductor, as shown in Figure 4-3. This 
region becomes the pattern matching template.

Figure 4-3.  Creating a Template Pattern

4. Click OK to accept the template. 

5. In the Main tab, enter Match Conductor 1 in the Step Name 
control.

6. Make sure the Reposition Region of Interest control is enabled.

7. Redraw or decrease the default green ROI so that it surrounds an area 
slightly larger than the template, as shown in Figure 4-4.
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Figure 4-4.  Limiting the Search Region

8. In the Settings tab, set Number of Matches to Find to 1.

9. Enable the Search for Rotated Patterns control.

10. Set the Angle Range +/– (degrees) control to 10 to enable the step to 
locate the best match possible within ±10° of the learned template 
angle.

11. In the Limits tab, enable the Minimum Number of Matches control 
and set the value to 1.

12. Click OK to add the step to the inspection.

13. Click the Run Once button twice so that Image 03.jpg becomes the 
active image.

Note The name of the active image is displayed in the Simulate Acquisition module of 
the inspection diagram.
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A fuse may be inverted when Vision Builder AI acquires an image of the 
fuse. This inversion causes the conductor to look different than the 
template, shown in Figure 4-5a. To prevent a good but inverted fuse from 
failing inspection, you need to learn a pattern matching template for the 
inverted instances of the conductor as well, shown in Figure 4-5b.

Figure 4-5.  Valid Templates for the Conductor

14. Copy and paste the Match Conductor 1 step.

15. Double-click the copy or click the Edit Step button to launch the step 
property page for editing.

16. In the Main tab, enter Match Conductor 2 in the Step Name 
control.

17. In the Template tab, click Create Template. A dialog box opens.

18. Draw an ROI around the conductor, similar to the region you drew in 
step 3.

19. Click OK to learn the inverted template.

20. Click OK to update the inspection.

Making Logical PASS/FAIL Decisions
Test the inspection using all of the images in the Tutorial 4 folder. 
Notice that all of the images fail inspection. The images fail inspection 
because the Match Conductor 1 and/or Match Conductor 2 steps fail, or 
because the Separation step fails.

By default, the Inspection Status is the logical AND of the Step Status of 
all the steps in the inspection. Because the conductor under inspection can 
match only one of the patterns you specified, one of the Match Pattern 
steps always fails, causing the entire inspection to fail.

a. b.
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Using the Decision Making step, you can create a Boolean result that is 
based on the results of the previous inspection steps. Vision Builder AI 
takes this Boolean result into account when determining the Inspection 
Status.

Follow these instructions to configure a Decision Making step that causes 
the inspection to pass when the conductor matches either the template in 
Match Conductor 1 or Match Conductor 2, and when the Separation 
step passes.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Decision Making step. The property page opens in the Main 
window.

3. Enter Decision Making in the Step Name control.

4. In the First Operand frame, set Step to Separation. Set Measure 
to Step Status. 

Current Value displays the value of the measurement based on the 
current image.

5. Make sure Second Operand is set to Constant, and Constant is set 
to True.

6. Click Add to add this expression to the Decision table.

7. In the First Operand frame, set Step to Match Conductor 1. Set 
Measure to Step Status.

8. Make sure Second Operand is set to Constant, and Constant is set 
to True.

9. Click Add to add this expression to the Decision table.

Notice the default binary operator AND in the last column of the 
Decision table.

10. In the First Operand frame, set Step to Match Conductor 2. Set 
Measure to Step Status.

11. Make sure Second Operand is set to Constant and Constant is set 
to True.

12. In the Decision table, click Add to add this expression to the Decision 
table.

13. Select the second expression, and click AND/OR to change the binary 
operator to OR.

14. Hold down <Shift>, and select the second and third expressions in the 
Decision table.

15. Click () to group the expressions.
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The Decision Making property page should look like Figure 4-6.

Figure 4-6.  Decision Making Property Page

16. Click OK to add the step to the inspection.

Setting Global Decision Making Properties
Follow these instructions to configure Vision Builder AI to pass the 
inspection when the Decision Making step passes, regardless of the results 
of individual steps in the inspection.

1. Select Tools»Configure Global Decision Making. The Global 
Decision Making Setup dialog box opens.

2. Select Inspection equals specified Decision Making Step result. 
Decision Making is the only Decision Making Step in the inspection 
and, therefore, is the default Decision Making Step.

3. Click OK.
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Testing the Inspection
Test the inspection to make sure it returns the results you expect. Table 4-1 
lists the test images, the inspection status to expect for each image, and an 
explanation of the status.

Table 4-1.  Expected Results for the Gasket Inspection

Image Name Inspection Status Explanation

Image 01.jpg PASS All steps pass but one 
Match Pattern step.

Image 02.jpg PASS All steps pass but one 
Match Pattern step.

Image 03.jpg PASS All steps pass but one 
Match Pattern step.

Image 04.jpg PASS All steps pass but one 
Match Pattern step.

Image 05.jpg PASS All steps pass but one 
Match Pattern step.

Image 06.jpg FAIL The Separation step fails 
because the blade 
connectors are too close 
together.

Image 07.jpg FAIL Both Match Pattern steps 
fail because the conductor 
is blown.

Image 08.jpg FAIL Both Match Pattern steps 
fail because the conductor 
is melted.
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Saving the Inspection
Save the example inspection with the following name and description:

• Inspection Name—Lesson 4

• Description—This inspection measures the distance 

separating the arms of a fuse and checks the 

integrity of the fuse filament.

Refer to the Saving an Inspection section of Chapter 1, Getting Started in 
Vision Builder AI, for more information.
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5
Inspecting an Object that Spans 
Two Image Frames

This chapter introduces the Select Image and Calculator steps. 

Assume that you need to measure the width of a wide wooden plank with 
high accuracy. The only cameras available for the application have low 
pixel resolutions.

To measure the width of a plank, you need to locate its left and right edges. 
If you were to set up the imaging system so both edges of a plank fit within 
an available camera’s field of view, the resulting image detail would be too 
low to yield accurate measurements. Because the required image detail 
exceeds the pixel resolution capability of a single camera, two cameras per 
plank are needed—one camera to acquire an image of the left edge and one 
camera to acquire an image of the right edge.

Follow the instructions in this chapter to create an inspection that measures 
the width of a wooden plank that spans two images.

Note Launch Vision Builder AI if it is not open. Refer to the Opening the Vision Builder 
AI Configuration Interface section of Chapter 1, Getting Started in Vision Builder AI, for 
more information.

Creating a New Inspection
Select File»New. Vision Builder AI loads a new, blank inspection into the 
Inspection Diagram window.

Simulating Image Acquisitions from Two Cameras
Follow these instructions to configure Simulate Acquisition steps that 
simulate acquiring images of the left and right sections of wooden plank.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Simulate Acquisition step. The property page for the step 
opens. 
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3. In the Step Name control, enter Acquire Part (Left).

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Vision Builder AI>\DemoImg\Tutorial 5 Left.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure the Cycle Through Folder Images control is enabled so 
that Vision Builder AI loads a different simulation image from the 
folder each time the step is run.

8. Click OK to add the step to the inspection.

Notice that Image 01.jpg contains a section of a ruler. Later in this 
lesson, you use the ruler to calculate the real-world width of the part across 
two images.

9. Click the Simulate Acquisition step again.

10. In the Step Name control, enter Acquire Part (Right).

11. Click the Browse button. The Select an Image File dialog box opens.

12. Navigate to <Vision Builder AI>\DemoImg\Tutorial 5 
Right.

13. Select the first image, Image 01.jpg, and click Open.

14. Make sure the Cycle Through Folder Images control is enabled so 
that Vision Builder AI loads a different simulation image from the 
folder each time the step is run.

15. Click OK to add the step to the inspection.

Calibrating the Image of the Right Edge
Follow these instructions to configure a Calibrate Image step that defines 
the type of calibration, the calibration parameters, and the real-world unit 
in which you want to express measurements.

1. In the Inspection Steps palette, select the Enhance Images tab.

2. Click the Calibrate Image step.

3. In the Step Name control, enter Calibrate Part (Right).

4. Click New Calibration to launch the calibration wizard.

For this example, assume that the camera that acquired the inspection 
images is perpendicular to the image plane and lens distortion is negligible. 
Based on these assumptions, you can use Simple Calibration to calibrate 
your images. Simple Calibration transforms a pixel coordinate to a 
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real-world coordinate through scaling in the x (horizontal) and y (vertical) 
directions. 

5. Double-click Simple Calibration to open the Simple Calibration 
Setup dialog box.

6. In Step 1 of 3, make sure Pixel Type is set to Square because the 
camera that acquired the images for this exercise has square pixels.

7. Click Next.

8. In Step 2 of 3, carefully click the 38 cm and 42 cm markings on the 
ruler in the image, as shown in Figure 5-1.

Tip You may need to scroll down to see the ruler at the bottom of the image. You may also 
need to zoom in on the image in order to click more accurately on the markings.

9. In the Correspondence Image - Real World control, enter 4 for the 
value, and select centimeter for the Unit.

Figure 5-1.  Defining the Pixel to Real-World Ratio

10. Click Next.

1 2
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11. In Step 3 of 3, click the 38 cm marking to define it as the origin of the 
calibration axis. Draw a line horizontally and to the right along the 
edge of the ruler to define the angle of the calibration axis, as shown in 
Figure 5-2.

Figure 5-2.  Defining the Origin and Angle of the Calibration Axis

12. Click OK to learn the calibration information and exit the calibration 
wizard. The Calibration and Axis tabs display information about the 
learned calibration.

13. Click OK to add the step to the inspection.

Locating the Right Edge of the Part
Follow these instructions to configure a Find Edges step that locates the 
right edge of the part.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Find Edges step. The property page for the step opens.

3. In the Step Name control, enter Find Right Edge.

Y
: 1 cm

X: 1 cm

1 2
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4. Hold down <Shift> and draw a line across the right edge of the part 
going from right to left, as shown in Figure 5-3.

5. In the Settings tab, disable the Auto Setup control.

6. Select First Edge Only from the Look for list.

7. Select Bright to Dark Only from the Edge Polarity list.

Figure 5-3.  Finding the Right Edge of the Plank

Notice the red square on the search line. The step searches along the 
search line for a sharp transition in pixel intensities, which usually 
represent an object edge. The red square marks the location of the right 
edge of the part.

8. Click OK to add this step to the inspection.

Find Right Edge
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Switching Images
Now that you have configured the inspection to locate the right edge of the 
wooden plank, you need to switch to the image of the left side of the plank. 
Follow these instructions to configure a Select Image step that makes the 
image of the left side of the plank active for processing.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Select Image step. The property page for the step opens.

3. In the Step Name control, enter Switch to Left Side.

4. In the Image Selection list, select Acquire Part (Left). The image of 
the left side of the part appears in the Main window.

5. Click OK to add this step to the inspection.

Calibrating the Image of the Left Edge
Follow these instructions to configure a Calibrate Image step that defines 
the type of calibration, the calibration parameters, and the real-world unit 
in which you want to express measurements.

1. In the Inspection Steps palette, select the Enhance Images tab.

2. Click the Calibrate Image step.

3. In the Step Name control, enter Calibrate Part (Left).

4. Click New Calibration to launch the calibration wizard.

Again, assume that the camera that acquired the inspection images is 
perpendicular to the image plane and lens distortion is negligible.

5. Double-click Simple Calibration to open the Simple Calibration 
Setup dialog box.

6. In Step 1 of 3, make sure Pixel Type is set to Square.

7. Click Next.

8. In Step 2 of 3, carefully click the 1 cm and 5 cm markings on the ruler 
in the image, as shown in Figure 5-4.

Tip You may need to scroll down to see the ruler at the bottom of the image. You may also 
need to zoom in on the image in order to click more accurately on the markings.

9. In the Correspondence Image - Real World control, enter 4 for the 
value, and select centimeter for the Unit.
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Figure 5-4.  Defining Pixel to Real-World Ratio

10. Click Next.

11. In Step 3 of 3, click the 1 cm marking to define it as the origin of the 
calibration axis. Draw a line along the edge of the ruler to define the 
angle of the calibration axis, as shown in Figure 5-5.

2 3
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Figure 5-5.  Defining the Origin and Angle of the Calibration Axis

12. Click OK to learn the calibration information and exit the calibration 
wizard. The Calibration and Axis tabs display information about the 
learned calibration.

13. Click OK to add the step to the inspection.

Locating the Left Edge of the Part
Follow these instructions to configure a Find Edges step that locates the 
left edge of the part.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Find Edges step. The property page for the step opens.

3. In the Step Name control, enter Find Left Edge.

4. Hold down <Shift> and draw a line across the left edge of the part 
going from left to right, as shown in Figure 5-6.

5. In the Settings tab, disable the Auto Setup control.

6. Select First Edge Only from the Look for list.

Y
: 1 cm

X: 1 cm

2 3
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7. Select Bright to Dark Only from the Edge Polarity list.

Figure 5-6.  Finding the Left Edge of the Plank

The step searches along the search line and marks the location of the 
left edge with a blue square.

8. Click OK to add this step to the inspection.

Calculating the Width of the Part
Now that you have located the right edge of the part in one image and the 
left edge of the part in another image, you need to combine the 
measurements from those images to determine the width of the part.

Find Left Edge
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Refer to the following equations as you configure the step.

Right (LC) = Right (RC) + (Origin R – Origin L) (5-1)

Part Width = Right (LC) – Left (LC) (5-2)

where Right (LC) = The x position of the right edge in the calibration 
axis of the left edge.

Right (RC) = The x position of the right edge in the calibration 
axis of the right edge.

Origin R = The x position of the origin in the calibration axis.

Origin L = The x position of the origin in the calibration axis.

Left (LC) = The x position of the left edge in the calibration 
axis of the left edge.

Setting Calculator Step Inputs and Outputs
Follow these instructions to select input measurements from the previous 
Calibrate Image and Find Straight Edge steps, and create output results 
for the calculated values. 

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Calculator step. The Calculator Setup Wizard opens.

3. Click Next to proceed with the wizard.

Notice the Input Measurements list. The list contains all of the 
measurable data from each of the previous steps in the inspection. 

4. Select the following measurements from the Input Measurements 
list:

• Find Right Edge»Edge 1.X Position (Calibrated)

• Find Left Edge»Edge 1.X Position (Calibrated)

5. Click Next.

6. Click Add New Output Result. A new output appears in the Output 
Results list.

7. In the Name control, enter Part Width. This output will contain the 
results of Equation 5-2.

8. Make sure Type is set to Numeric.

9. Click Add New Output Result again.
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10. In the Name control, enter Right (LC). This output will contain the 
results of Equation 5-1.

11. Make sure Type is set to Numeric.

12. Click Finish to close the Calculator Setup Wizard.

The Main window now displays a diagram with the measurement inputs 
and result outputs you specified in the Calculator Setup Wizard, as shown 
in Figure 5-7. The diagram also contains a default Boolean result named 
Step Result. You can connect the result of a computation to Step Result, 
which changes the status of the Calculator step to the result of the 
computation. Refer to the Making Logical PASS/FAIL Decisions with the 
Calculator Step section for more information about Step Result.

Figure 5-7.  Calculator Diagram Elements

Notice that the inputs and outputs are framed with color and have codes at 
the bottom of their frames. These colors and codes visually group inputs 
and outputs into their respective data types—numerics, Booleans, or 
strings.

13. To simplify references to the input measurements, change the labels of 
the inputs to match their corresponding variables in Equations 5-1 
and 5-2, as follows:

• Triple-click the label of Find Right Edge 1.XPosition 
(Calibrated) to highlight the entire label, and type Right (RC).

• Triple-click the label of Find Left Edge 1.XPosition 
(Calibrated) to highlight the entire label, and type Left (LC).

14. To simplify the process of connecting the diagram elements later in 
this chapter, arrange the elements into the configuration shown in 
Figure 5-8 by dragging them to their new positions.
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Figure 5-8.  Arranging Diagram Elements

Adding Operators and Constants
Earlier in this chapter, you set calibration axis origins for the right and left 
sides of the part using Calibrate Image steps. These origins are the only 
elements of Equations 5-1 and 5-2 not yet represented in the Calculator 
diagram: (Origin R and Origin L). 

In step 11 of Calibrating the Image of the Right Edge, you set the origin 
of the right side to the 38 cm marking of the imaged ruler. In step 11 of 
Calibrating the Image of the Left Edge, you set the origin of the left side 
to the 1 cm marking of the imaged ruler. Therefore,

(Origin R – Origin L) = 38 – 1 = 37. 

The distance between the calibration axis origins is a constant value. Add a 
constant with the value 37 to the Calculator diagram.

1. In the Functions palette, click Numeric.

2. Click the Num Const operator. Click inside the Calculator diagram 
below the Right (RC) input measurement to place the numeric 
constant on the Calculator diagram.

3. Double-click the numeric constant and type 37 to set the value of the 
constant.
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4. Click the Add operator in the Functions palette. Click inside the 
Calculator diagram to the right of the Right (RC) input measurement.

Tip Place the Add operator close enough to the Right (RC) input so that the Calculator 
step automatically connects the two elements with a wire.

5. Enable the Show Help Window control on the Main tab of the 
Calculator step to launch the Help window, or click the Help button 
in the Calculator diagram toolbar. When you move your cursor over 
certain elements within the Calculator diagram, information about that 
item shows in the Help window.

6. Place your cursor over the Add operator. Notice in the Help window 
that the operator has an x input terminal, y input terminal, and x+y 
output terminal.

7. Click the Subtract operator in the Functions palette. Click inside the 
Calculator diagram to the right of the Right (LC) input measurement.

Your Calculator diagram should look similar to the one in Figure 5-9.

Figure 5-9.  Unconnected Diagram Elements
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Connecting the Equation Elements
Follow these instructions to wire the diagram elements together such that 
they form Equations 5-1: Right (LC) = Right (RC) + (37).

1. Place your cursor on the small, triangular terminal located on the right 
side of the numeric constant. The cursor changes into a Wiring tool.

2. Use the Wiring tool to click the terminal and release the mouse. As you 
move the cursor across the Calculator diagram, the Calculator step 
draws a wire between the terminal and the Wiring tool as though the 
wire were unwinding from a spool.

3. Without holding down the mouse button, move the cursor to the y input 
terminal of the Add operator. The y input terminal blinks. Use the 
Wiring tool to click the y input terminal and complete the connection.

4. Click the output terminal of the Add operator, and connect it to the 
input terminal of Right (LC).

Tip If you do not terminate a wire correctly, the wire is broken and appears as a dashed 
black line with a red X in the middle. Click Remove Broken Wires in the Main tab to 
remove broken wires.

Follow these instructions to wire the diagram elements together such that 
they form Equations 5-2: Part Width = Right (LC) – Left (LC).

1. Place the cursor on the wire that connects the Add operator to 
Right (LC). The cursor changes into the Wiring tool.

2. Click the wire, and connect it to the x input terminal of the Subtract 
operator.

3. Click the Left (LC) output terminal, and connect it to the y input 
terminal of the Subtract operator.

4. Click the output terminal of the Subtract operator, and connect it to 
the input terminal of Part Width.

Your connected Calculator diagram should look similar to Figure 5-10. 
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Figure 5-10.  Connected Elements of Calculator Diagram

5. In the Calculator step property page, click the Measurements tab.

6. Click Compute Results to see the results of the calculation thus far.

Making Logical PASS/FAIL Decisions with the Calculator Step
Now that you have a created a diagram to measure the width of the part, 
you need a way to verify that the width meets manufacturing specifications. 
Follow these instructions to add diagram elements that compare the 
measured width to minimum and maximum width tolerances and decide 
whether the plank passes inspection.

1. Click the up arrow in the Functions palette to return to the main 
palette.

2. Select the Comparison palette.

3. Click the Less? operator in the Comparison palette. Click inside the 
Calculator diagram below Part Width.

4. Connect the wire between Subtract and Part Width to the x input of 
the Less? operator.

5. Click the up arrow in the Functions palette to return to the main 
palette.

6. Select the Numeric palette.

7. Click the Num Const operator in the Numeric palette.
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8. Click close enough to the y input of Less? to automatically wire the 
numeric constant and y input together.

9. Type 40.5 to set the maximum width a plank can be to pass the 
inspection.

10. Click the up arrow in the Functions palette to return to the main 
palette.

11. Select the Comparison palette.

12. Click the Greater? operator. Click inside the Calculator diagram 
below the Less? operator.

13. Connect the wire between Subtract and Part Width to the x input of 
the Greater? operator.

14. Click the up arrow in the Functions palette to return to the main 
palette.

15. Select the Numeric palette.

16. Click the Num Const operator.

17. Click close enough to the y input of Greater? to automatically wire the 
numeric constant and y input together.

18. Type 39.5 to set the minimum width a plank can be to pass the 
inspection.

19. Click the up arrow in the Functions palette to return to the main 
palette.

20. Select the Boolean palette.

21. Click the And operator. Click close enough to the left side of Step 
Result to wire the two elements together.

22. Connect the Less? output to the x input of And.

23. Connect the Greater? output to the y input of And.

Your completed Calculator diagram should look similar to Figure 5-11. 
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Figure 5-11.  Calculator Diagram with Decision-Making Abilities

24. Enable the checkbox on the Limits tab to base the status of the entire 
inspection on the result of the Step Result.

25. Click OK to add the step to the inspection.

Testing the Inspection
Test the inspection to make sure it returns the results you expect. Table 5-1 
lists the test images, the inspection status to expect for each image, and an 
explanation of the status. 

Note Results may vary slightly based on the accuracy of the calibration and the edge 
detection location.

Table 5-1.  Expected Results for the Plank Inspection

Image Name Part Width Inspection Status

Image 01.jpg 40.09 cm Pass

Image 02.jpg 40.12 cm Pass

Image 03.jpg 40.34 cm Pass
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Saving the Inspection
Save the example inspection with the following name and description:

• Inspection Name—Lesson 5

• Description—This inspection measures in real-world 

units the width of a wooden plank. The right and left 

edges of the plank were acquired using different 

cameras because the plank is too wide to fit in one 

camera’s field of view given the required measurement 

accuracy.

Refer to the Saving an Inspection section of Chapter 1, Getting Started in 
Vision Builder AI, for more information.

Image 04.jpg 39.36 cm (too short) Fail

Image 05.jpg 40.97 cm (too long) Fail

Table 5-1.  Expected Results for the Plank Inspection (Continued)

Image Name Part Width Inspection Status
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers 
and updates, a searchable KnowledgeBase, product manuals, 
step-by-step troubleshooting wizards, thousands of example 
programs, tutorials, application notes, instrument drivers, and 
so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

For information about other technical support options in your 
area, go to ni.com/services or contact your local branch at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local If 
you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can 
visit the Worldwide Offices section of ni.com/niglobal to access 
the branch office Web sites, which provide up-to-date contact 
information, support phone numbers, email addresses, and current 
events.
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Glossary

Symbol Prefix Value

m milli 10–3

C

coordinate system A reference location (origin) and angle in an image that ROIs can relate to 
when positional and angular adjustments of the ROI are necessary. 
A coordinate system is depicted by two lines representing the orientation 
and direction of its two axes.

D

data type A format for information. Acceptable data types for most functions are 
numeric, array, and string.

F

field of view The area of inspection that the camera can acquire as an image.

FieldPoint A modular distributed I/O system with industrial-grade performance.

focal point The pixel location in a pattern matching template whose coordinates are 
returned as the location of a match in the inspection image.

I

inspection A vision inspection application created in and ran from Vision Builder AI 
that can perform inline or offline visual inspections.

intensity The gray-level value of a pixel in a grayscale image.
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M

match score A number ranging from 0 to 1,000 that indicates how closely an area of an 
acquired image matches the template image. A match score of 1,000 
indicates a perfect match. A match score of 0 indicates no match.

O

object A connected region or grouping of pixels in an image in which all pixels 
have intensity levels in the same range.

P

pattern matching The technique used to quickly locate a grayscale template within a 
grayscale image.

pixel picture element—The smallest division that makes up a digital image. For 
measurement tasks, optimum pixel dimensions are square (aspect ratio of 
1:1, or the width equal to the height).

R

resolution The number of rows and columns of pixels. An image composed of m rows 
and n columns has a resolution of m × n.

ROI region of interest—An area of the image that is graphically selected from a 
window displaying the image. This area can be used to focus further 
processing.

S

spatial calibration Assigning physical dimensions to the area of a pixel in an image.

step A component of a Vision Builder AI inspection that performs a specific 
visual inspection task or supporting tasks, such as decision making and 
serial communication.
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T

template Pattern that you are trying to match in an image using the Match Pattern or 
Match Color Pattern steps. A template can be a region selected from an 
image or it can be an entire image.
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